[Guide] Factory Reset of JingPad A1

Hi everyone,
this is a transposed guide you can find in the JingOS Shopify page at the following link:

If you need to do a factory reset, please follow the steps.

If you can load into the system

  1. Go to “Setting”
  2. Go to “System & Update”
  3. Select “Factory Reset”

If you cannot load into the system

  1. Press Power for 15 sec

  2. Press Power for half a second and later press “Volume down”

  3. Keep holding bot “Power+Volume down”, a text menu appear

  4. Select “Factory reset”: use Volume bar to navigate and Power to select items)

Have you tested it successfully? I am trying to reset my jingpad as it stopped booting up to login screen (probably too much plasma packages were uninstalled alongside with some kde apps) but no success. I can’t turn it off. It keeps rebooting when I try to turn it off and then freezes on JingPad booting screen even if I press power+volume_down :frowning: I hope it is not bricked.

Edit: I was able to do factory reset. You have to unplug tablet from power :upside_down_face: BTW you can wipe out only system partition and leave user date untouched. If you create new user with the same name as old one, your profile (home directory) is restored.

I am having the exact same issue, stuck on splash screen, can’t get into recovery mode because I can’t get it to turn off, just keeps turning itself back on, very frustrating! Mine is not connected to a power source.

UPDATE: tried letting the battery run down to get it to turn off, as soon as I plugged into AC the tablet automatically turned back on, so I disconnected the power and attempted to turn it off - once again it immediately turned back on.
My Jingpad is effectively a nice looking paperweight at this point :worried:

Reached out to JingPad support who got back to me really quickly. When turning off the device it is important to keep holding the power button for 15 seconds, even if the device appears to power off earlier than that (the device actually restarts and isn’t turning itself back on at all!) for me this was about 16 seconds and this time it stayed off.
It was then straightforward to get to the recovery menu and my device is now back up and running :grinning:

Only way I found was to use adb shell and poweroff command line !

$ sudo adb shell
# poweroff

Then I quickly unplug the USB from the JingPad A1, which, this time, stay off…

I’ve tried all of the above :confused:

It was working fine today and then I decided to apt full-upgrade -y the device and I think the battery died during that.
it seems like it is not charging at all, it goes up to 2.5 watts for a few seconds then back to zero and back up again. I’ve tried various other chargers for several hours but it won’t turn on at all.

I’ve also tried all the button press combos, no luck.

screen stays dark, no fastboot or adb interface present

Any recommendations for how to open the tablet to remove the battery?

@MariusQuabeck Do not open it.
Please, try to follow this guide:

After flashing, you probably will be able to properly charge it.

I can reboot to recovery mode

just by typing from ssh terminal:

‘sudo reboot recovery’

memo: I have setup ssh before.

This worked for me. I did some kind of update that nuked the pad’s ability to use wlan0, possibly due to abuse of apt installing random crap. I did have to «sudo reboot -f recovery» to get into the recovery mode. I…

  • recharged fully
  • unplugged the cable
  • clicked factory reset (but chose to keep user data)

…and after a few minutes it came back to the recovery mode, and I just chose the reboot option, and everything worked.