[Guide] Telegram - How to install Telegram on JingOS ARM

Hi all,
after installing Synaptic (how to → here) I saw Telegram-Desktop package has some related packages missing on my JingPad A1 (JingOS ARM). So I decided to find the best way to install it.

In my procedure I decided to use Snap APP, a common package system made by Canonical.
So, first of all, follow my guide on “How to install Snapd” (open it in a new page):

…And now, install Telegram:

sudo snap install telegram-desktop

Now, please try do open the Telegram desktop icon:

  • If the app starts, you are ready to use it;
  • If the app doesn’t start, please continue with instructions made by “Shinkamui” on the Telegram Group

Install Gedit text editor (you can instead use nano or other text editors…):

sudo apt update && sudo apt install gedit

And now run the following two commands (separated commands):

xhost +
sudo gedit /usr/share/applications/telegram-desktop_telegram-desktop.desktop

You have to identify the “Exec” line, and add “QT_QPA_PLATFORM=wayland”, like the following example:

Exec=env QT_QPA_PLATFORM=wayland telegram-desktop BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/telegram-desktop_telegram-desktop.desktop

Something like this:

Ok, now you can open Telegram Desktop!

You probably need to change the Interface Scale (UI), so open the Main Menu of Telegram:

Open Settings:

And modify the Interface scale to 150-200%:

Perfect, now you can properly use Telegram Desktop on your JingPad A1 running JingOS ARM!

…If the Telegram icon doesn’t appear on desktop, so you didn’t follow this guide, you can manually add it:

sudo cp /var/lib/snapd/desktop/applications/telegram-desktop_telegram-desktop.desktop /usr/share/applications/

Have a nice day!

PS: If you know how to install Teelgram in a different way please comment this topic!
If you like my guide please click on <3

5 Likes

Ciao @Maxximo88, thanks for the how-to. It works but the font size is way to small. I can’t read anything. And there is no setting to change that. Any idea?

I solved the problem, but I don’t really know how :grimacing:. I changed the language from English to German and then I suddenly was able to scale the settings. Maybe I was blind before or it wasn’t there. But chosing 200% solved my issue. Telegram looks now as it should be.

Your guide is great, thank you. However, Telegram is totally unusable for me because I can’t change the font size. Can’t read it.

Hi Maxximo88,
I’ve installed telegram as discribed, but it doesn’t start properly. The telegram start-screen shows, but the application doesn’t open.
Any ideas?
Thanks, Michael

We have noticed this issue on JingOS ARM V1.1. When we have a solution, we will let you know

1 Like

Thanks @August !

1 Like

Thanks. Good to know! :slight_smile:

1 Like

Hi @Kugelraumer
I edited the guide, now it’s working fine!

2 Likes