How do we add a ppa?

The app store is pretty sparse right now. I downloaded synaptic manager, but it will not work.

I want to install conky manager to get the gui and cannot add the ppa. I tried to edit the sources file and was unable to do that. …of course I am not sure I opened root Thunar as the text is all Chinese =(

What package manager can I download to add extra software or how can I add the ppa?

Hi @Glockdoc , do you already tested the following terminal commands before trying to add repos?
sudo apt update && sudo apt full-upgrade
sudo apt install software-properties-common

And later:
sudo add-apt-repository ppa:repo-name

I had not run full-upgrade and install software-properties-common. Also was using a different command.

Now when I tried to add the ppa the last line says " Error: could not find a distribution template for Jingos/focal"

Which software are you willing to install?
It seems the software installation process could not identify OS version to install the proper version…

UGH!! I use MX Linux so I am used to that! LOL

Trying to add the ppa so I can install conky-manager.

Somewhat of a mute point and KSysguard will do pretty close to the same, just not on screen all the time. Plus, I found a glitch with my set up. When I start regular conky through the terminal, which leaves the monitor on the home screen all the time, I cannot open another terminal unless I close conky. Also cannot open a terminal if I have the Eddie GUI for AirVPN running. When I try to open another terminal it just goes to Eddie.

I have been able to load some of the software I prefer over the pre loaded stuff with ease though.

On a side note it looks like it is just you and myself on the forums…

Still having the same issue trying to add the ppa to get anbox installed.

Maybe it’s because when you add the ppa it looks for the distribution add the proper one and it’s Jingos/focal instead of Ubuntu/focal

You can try 2 things:

  • Rename the OS release name in /etc/lsb-release

  • Or add the ppa repo to the sources list, but i can’t find the ppa for anbox in ubuntu focal the newest one is for ubuntu disco (maybe that’s the issue):
    deb http://ppa.launchpad.net/morphis/anbox-support/ubuntu disco main

If I change the os name say to “ubuntu 20.4” isn’t that going to cause issues with my other packages and updates? Or are you saying “change it, add the ppa and install, then change it back”?

The safer way is to add this to your sources.list

deb http://ppa.launchpad.net/morphis/anbox-support/ubuntu disco main

Then update and try to install anbox.