How to flash JingOS ROM on JingPad C1/A1

Warning: This process will wipe your personal data on your JingPad C1.

Pre-requisitions:

  1. Download image:

md5sum: f6c182b1393eb20eca064bf78ce1569b

sha256sum: 8716001a57d8b487cc5d6490f5490ecd352484bf17189559b45622c85864a1ed

  1. Download flash toolkit: A1_flash_tools.zip - Google 雲端硬碟
  2. Install the flash tool on a Windows computer. You only need to install the driver.

N.B. You cannot finish this process using a virtual machine.

Flash the device

Open the flash tool

Load the image package

Connect the JingPad to the computer using the pad’s USB type-C socket

Click on the button to start the flash process

Click the “Power” button then the “Volume Down” button. Do not release the buttons until the JingPad logo appears.

Flashing of the device starts (the progress is shown on the UI of the flash tool)

Wait until the JingPad shows the following screen:

Unplug the USB cable and start the device

  1. The device will start to boot.
1 Like

is it possible to flash jingos onto the c1 without a windows device? thanks!

Sorry, we haven’t test other OS yet.

Also would love to see/hear more about alternatively OS options for flashing the JingPad.

Thanks!

Hi @mphilip1
the flashing tool is related to SoC manufacturer, and UNISOC released it only for Windows at the moment.

Anyone else out there have trouble with flashing the JingOS rom onto the JingPad C1?

I’ve got ResearchDownload loaded onto a Windows PC, PAC file loaded, ‘start’ the flash, plug the JingPad, hold Power+“Volume-down” for over a minute and ResearchDownload just shows a loop of status “checking baudrate” or “unplugged”.

Anyone able to help?

Mine worked, but there were long delays waiting for the ROM to finish the flash even after the DownloadManager said it was complete (20 minutes?)

The JingPad C1 arrived today. I don’t see much functionality in the android version so I want to flash JingOS ROM.

Do I need to enable developer options and allow unlocking the bootloader and enabling changes over USB?

I flashed this version on C1,but can’t reboot.I tried update os,but get same result.

Was this using the UniSoc ResearchDownload program for ROM flash?
Mine would just hang in a loop if I managed to get any response at all.

Update: Company just pushed a refund to my order after I sent my SN, but nothing else yet about if the device will ever get re-flashed.

Fingers crossed, since the stock “android” install is pretty limited. Won’t allow Google Play services, so most US apps are unable to function….

YES PLEASE! I don’t even own a Windows computer. :frowning:

I don’t own a windows either, so it was extremely inconvenient to get jingos flashed on the jingpad. Will echo the need to have non-windows options for this. But I managed to wrangle a crap computer from someone and following all the steps worked. Looking forward to checking out jingos.

I’m having trouble. I got the driver installed on a Win10 machine, so it recognizes the JingPad C1. Installed and opened the flash tool, loaded the pac file, connected JingPad C1 to the computer, then hold down power + volume down but never get the JingPad logo. I’ve held it until the process even finished and seen “Success” a few times now in the flash tool UI but no go.

Have I bricked my device??? :frowning:

I also tried yesterday to flash my C1 with no success. Had the same issues. No logo appearing, system would show the android boot logos, but after that just a black screen.

I have a C1 model and I am afraid to flash JingOS on it until I see some more successful installs posted by people and a little more detailed instructions. I am a novice at flashing tablets but not a novice at desktop Linux.

I think I might wait for Ubuntu Touch to mature and flash that.

At least you got the Android boot logos! All I get is a one second buzz/vibrate every 8-10 seconds while holding the power button. :frowning:

I just performed this process on my early-bird JingPad A1 and so far as I can tell it has worked. But I have some notes below to share.

I hadn’t used my A1 in a few weeks/months and tried to do some updates last week. The updates failed because the root partition was full. When I went to reboot, I was stuck in a boot-loop.

Some notes:

  1. Mine would not power down. Ever. If I held the power button for 10, 15, 20, 30 seconds it would just reboot after 8 seconds or so.
  2. I could get something closer to a shutdown by holding Power and Volume Down. It would then not reboot until after I let the buttons go.
  3. The Factory Reset process did not work for me at all (the hold Power + VolDown during boot to get to recovery menu.)

So I came here, did the two downloads, and started the process above. Some notable exceptions:

  1. Since I could not power down, I didn’t. I just plugged the tablet into my Windows PC.
  2. I loaded up the ResearchDownload.exe program and followed the steps up to “Click on the button to start the flash process”.
  3. The next instruction is “Click the “Power” button then the “Volume Down” button. Do not release the buttons until the JingPad logo appears.” This did NOT work for me, and caused the 8-second boot loop to happen. I could see that I was getting a “User Cancelled” status in the ResearchDownload program.
  4. So I just let go of the buttons. My JingPad’s screen went black. It took about 5min (timer says 312s) to do things, but I could see in the ResearchDownload program performing actions, including uploading the software to the device.
  5. At the end of the process the ResearchDownload program said Step “POWEROFF” and Progress “Ready” but my JingPad’s screen was still blank (I did not see the “disconnect from power” screen at this time.)
  6. I did disconnect the cable anyway, since it said it had already powered off.
  7. I cannot remember if I pressed the power button or if it just started on its own, but shortly after the device started, it began to a) show the JingPad logo, b) show a colorful-ball animation, and then c) after 3-5min, it showed the “disconnect from power to reboot” logo as pictured above. As I was already disconnected, that went away shortly.
  8. The device did not reboot by itself. I held the power button for 1-2 sec (not long) and got the familiar power-up buzz. The JingPad logo appeared for 1min or so, and then disappeared and I landed on the New Device Out-of-Box Experience (OOBE) which was a white screen with “Hello” and a blue button for “Starting now”.

Hope this helps other people!

3 Likes

After trying again, following these steps. It failed, but then I tried installing the android image again and the tablet booted with the Linux start screen.

So somehow I now have JingOS installed on the C1.

I followed your steps and the only difference for me has been nothing but black screen, and prior to seeing your instructions, at Step 5, I was disconnecting the cable while Progress said "Passed’. I disconnected it this time after Progress said ‘Ready’ by hitting the power button for a couple of seconds which made it go from ‘Passed’ to ‘Ready’.

But still no joy, I have a black screen. And now, I don’t even get the familiar buzz after 8-10 seconds.