HP Elite 2nd try

Hp Elite x2 2011 G1:

originally a windows 8 tablet touch screen with pen, added attachable keyboard direct install after tweaking bios for legacy versus uefi 64 bit . (Not virtual install)

Worked like x86 install for Jing Os 0.81
16x9 1080p display tweaked ok

Updates numerous and individually laborious & clumsy graphically terminal updates available but not stable,

bluetooth for mouse etc not working, terminal processes permit various ubuntu linux app installs but long process seem to stifle daily driver potential.

Now attempting Jing OS 0.9.

0.9 greatly improved, very nice home screen geometric graphic .

but problem connecting to wifi because password started with a number rather than a letter and system did not accept sequence

worked with usb/ethernet jack interface for wired internet and later for wifi on a different router with password that started with a letter. Bluetooth now functional for speaker.

Added “startpage,” search engine for privacy to chromium and firefox.

Most recent Kernel updates missing support on Github and unsigned.

Terminal commands with multiple Chinese dialects overlay filter making text entry labourious and hit and miss for stable command and application support.

Hi @jee
I think you can follow 2 parallels ways.
First of all, open an Issue on GitHub:

Second phase, try to install the last generic Ubuntu Kernel (it probably integrates your drivers):
https://kernel.ubuntu.com/~kernel-ppa/mainline/

Let me know about it…

no gain on those approaches.

0.9 improved greatly but won’t give a functional synaptic after install, Thunderbird {text to small to read comfortably}, libreoffice & ppa’s blocked in unsupported install. Many applications from unstable ppas。

A way to go yet 。。。