JingOS on Lenovo MIIX 310 (Intel Atom X5 Z8350, RAM 2 GB, 32 GB eMMC)

Good evening, fellow JingOS community :slight_smile:

First of all, thanks to the JingOS/Pad team for all their hard work, it all looks very promising to me!!! (For sure I already ordered a JingPad, YAY)

Couple of days ago I was digging out my Lenovo miix 310, just installed the lovely JingOS. First I was flashing the OS live after tweaking (display rotation etc.) everything worked as expected, got a instant wifi connection and moreover its great how snappy and intuitive JingOS behaves.
So since I was still on live I just did a clean installation to have the OS on drive. I did some partitioning (was a bit tricky first) but worked out pretty well. After installation finished all was working as expected besides the kind of already known issues from other devices that the network (wifi driver) was not working anymore.
I tried several solutions which where posted here at the Jing forum and even tried some other solutions from Ubuntu forums but no luck yet.
I also tried the wifi options in Plasma settings to set it up manually and also via terminal (sudo nmtui) etc…

So I am pretty sure the devs are currently quite in a rush :wink: so no worries just if maybe someone of the community has any solution?

Cheers!
Harald

Hi @Harald
I edited your title adding basic hardware info.
So, please run the following commands on terminal:

sudo update-pciids

And:

sudo lshw -C network

In addition:

lspci -nnk | grep -A2 0280

Let me know the output of last two commands.
Thanks.

1 Like

Hey, thanks for the quick reply and for updating the title :+1:t3:

so since there is no connection the first command failed:

jingos@localhost:~$ sudo update-pciids
Resolving pci-ids.ucw.cz (pci-ids.ucw.cz)… failed: Temporary failure in name rsolution.
wget: unable to resolve host address ‘pci-ids.ucw.cz’
update-pciids: download failed
jingos@localhost:

second command just was showing once:

sudo lshw -C network
[sudo] password for jingos: 123456
PCI (sysfs)
USB
jingos@localhost:

third one didn’t output something:

jingos@localhost: sudo lspci -nnk | grep -A2 0280
jingos@localhost:

Thanks anyway for the help.

Best
Harald