JingPad A1 - How to install Ubuntu Touch

Hi everyone,
I dediced to write this Guide in order to allow all users to test an alternative OS for JingPad A1.

All your personal data will be wiped out from JingPad A1. We are not resposible about what you do with your tablet following this guide. I’ve tested it before publish to this forum, and it worked.



  1. Copy ubuntu.img to /home folder of your JingPad A1 (not /home/user, just /home).
  2. Copy vendor.img to /home folder of your JingPad A1 (not /home/user, just /home).
    This is the correct location (see, both files are in /home):

Open the Terminal on your JingPad and run:
sudo reboot -f recovery

Now, on your JingPad, please enter in “fastboot” mode.

From Terminal of your Computer:
sudo ./fashboot devices
…The terminal of your Computer will show the Device ID of your JingPad A1…

sudo ./fastboot flash boot boot.img
…This is the real step of boot flashing…

sudo ./fastboot reboot

Finally, the device will reboot in Ubuntu Touch.
It require several time to succesfully boot into Ubuntu…

If you like my guide please click on <3


I would love to try this, but right now, I can’t even get beyond a black screen (C1 that came pre-loaded with Chinese version of Android 10, which I’ve subsequently tried to flash with JingOS, no luck) and I have no idea if my unit’s bootloader is unlocked or not.

I have the same problem. This is very discouraging. Looking back now I should have taken the refund when offered.

As always, thank you.

If you could expand the guide with more detailed instructions it would be great.

Developers will get it just like it is written. Non devs maybe, maybe not.

Just assume we know nothing other than how aggravated we are with the Jing OS :slight_smile:

How is the functionality? Can you report what works and what doesn’t?

1 Like

Just requested my boot loader unlock. Looking forward to playing with Ubuntu Touch. Thank you for your efforts!

I wish I could get to the details to request my boot loader unlock!

Good luck.

use the adb reboot fastboot to get into the fastboot menu, at least i had extreme trouble with the fiddling of the power button and the volume down, whilst command line works reliable :wink:

Thank you for this guide and prebuild image files.
Just flashed Ubuntu Touch. Makes the tablet much more useable and more responsive. :smiley:

Important for my successful flashing operation was one step, described in the readme of the package, but missing here:

(directly after copying ubuntu.img to /home)

From the Terminal of JingOS run:
sudo cp /opt/jingos/android_hal/4.14.133-*/vendor.img /home/vendor.img

1 Like

Support from UBports!
How to Install Ubuntu Touch on the Jingpad A1/C1 | UBports Forum

This is encouraging yet discouraging at the same time:

@bboett would you be so kind as to provide a few more details on what you mean by ‘adb reboot fastboot’ and how to get to that?? I get nothing on the screen, it stays black from everything I’ve attempted. Only thing I get is a 1-2 second buzz every 10-12 seconds while holding the power button down. NOTHING else!


just seeing that my mail answer didn’t make it through…
ok, forget the manipulation of the tab, only worked once or twice in hundreds of attempts, at least for me…
just connect a (suitable, beware of charge only) cable to the tab and hit
adb reboot fastboot
on any term, works flawlessly and reliably

I will try this … I’m assuming this is while the tab is connect to a Linux machine??



Where can i find the vendor.img? Because i did the command in the readme file, but it did not work.

Thank you very much for this help.
I’m having some problems installing Ubuntu Touch. What JingOS version do we need? Where and how should I install it?
My device is already unlocked, but I can’t install UbuntuTouch.


I wish I had some answers for you but I don’t. I got the JingPad C1 back in March. It’s been so long now that I forget everything I tried but basically, I bricked it and haven’t had any luck in bringing it back to life. But I’m encouraged to see some activity in this forum again!

Perhaps I will get back to this in a few weeks as fall has arrived in the Midwest. I will post here with any progress I might make (I’m not a developer, just want to get this tablet working in any way possible).