JingPad C1 won't boot

I’ve been attempting to flash my C1 to get JingOS on it (came preloaded with Android ROM in Chinese) following the instructions as provided on this forum. I have been unsuccessful to this point. As of now, when I hold the power button down, the pad vibrates for just a second after holding it down for 8-10 seconds.

A factory reset will not work either as I’ve tried the power + volume down sequence but I get nothing, no vibration, no logo, just black screen.

Are there ANY OTHER button pressing sequences or any other things I can try to get the JingPad going?

Thanks in advance for any advice! I have a nice looking, well built paperweight at the moment.

Same here. After an update, the only thing I get is a black screen. Tried the power+volume down to revert to factory settings but in vain.

Hello, the flashing guide in the forum will be different from the actual operation. First, when you start flashing, press the volume down button and the power button, the device doesn’t display anything (aka a black screen). Therefore, in the guide, it is required to press the start button of the GUI of the flashing tool before performing the above operations. The device will start flashing when you hear the beep of a device plugged into the computer, and see the progress bar on the GUI begin to show progress and Downloading. Then, when the GUI shows green Passed, the device flashing has been completed, you need to press the stop button on the GUI and long press the power button on the device to manually power on. Please note, do not unplug the USB data cable at this time, until the device displays the following interface before unplugging the data cable and turning it on again manually. After booting again, the device will display the blue JingOS icon and Start button, and you are ready to use JingOS. Good luck and thank you for supporting JingOS. Moore.
image