Terminal issue - "cat > myfile.txt" Ctl+d fails on my system

Help, please…

Today I entered a cat command (cat > myfile.txt) but couldn’t get out of it.

Ctrl d or D should do the trick. But fail. So I’m stuck in cat—terminal unusable.

Thanks,

LRP

Ctrl+c ?? Tried here and it works as you described, Ctrl+d worked OK.

Hi Steven,

Thanks.

Ctl+d fails on my system. Terminal accepts characters, but is frozen in cat loop.

I’m running JingOS 1.1.1 on the JingPad A1.

I’ve tried holding down the control key with one finger while pressing lower-case d with the other as well as pressing the two keys in sequence.

Fortunately, it’s a new system without much on it, so I may try a factory reset to bring back terminal functionality.

But if it is indeed a bug and not user glitch on my end, it’s serious.

All the best.

LRP

I reported this problem weeks ago to Jing. They asked for a video. Now it’s weeks later with no solution or even response.

I bought this tablet for programming on the command line. But the bug reported above makes it unusable.

Can’t say how disappointed I am.

LRP

Hi @LRP ,
do you opened an issue on Github?

Thanks.

I didn’t see one, so I opened one myself. The problem appears to be any control character at all on the virtual keyboard. It’s issue 126.